Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um Ihre Login-Informationen zu speichern, wenn Sie registriert sind, und Ihren letzten Besuch, wenn Sie es nicht sind. Cookies sind kleine Textdokumente, die auf Ihrem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies dürfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die Sie gelesen haben und wann Sie zum letzten Mal gelesen haben. Bitte bestätigen Sie, ob Sie diese Cookies akzeptieren oder ablehnen.

Ein Cookie wird in Ihrem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dassIhnen diese Frage erneut gestellt wird. Sie können Ihre Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Bitte 'Schatten über Riva'-CD einlegen
#1
Hallo!
Ist es eigentlich möglich auch von "Schatten über Riva" eine ISO zu erstellen, damit das Laufwerk nicht ununterbrochen arbeiten muss? Ich habe bereits mehrere Tools versucht (CloneCD, CD2ISO, Alcohol, ...) - leider ohne Erfolg. Immerwieder kriege ich die Fehlermeldung "Bitte 'Schatten über Riva'-CD einlegen". Ich vermute, dass es am Kopierschutz liegt, denn ansonsten ist alles korrekt eingestellt/gemountet...
Zitieren
#2
Hallo Aoshi und willkommen im Forum, :wave:

Ja, ist möglich. Zusätzlich muss man aber ein virtuelles Laufwerk anmelden, das mit dem ISO geladen wird. Dieses Laufwerk meldest du als "CD-ROM" an. :)
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#3
Also, ich habe folgendes schon versucht:

1.
die mit CloneCD/CD2ISO/Alcohol erstellten ISOs mit "DAEMON Tools" gemountet und das virtuelle Laufwerk von "DEAMON Tools" in "DOSBox" noch einmal als einfaches CD-ROM-Laufwerk eingebunden (mount d e:\ -t cdrom)

2.
"D-Fend" installiert und nach folgender Anleitung konfiguriert:
http://nlt-hilfe.crystals-dsa-foren.de/page.php?23

Irgendwie kann ich mir nicht vorstellen, dass es an der Einstellung liegt. Vielleicht braucht man ja doch einen No-CD-Crack...
Zitieren
#4
Hast du auch den Haken bei "Enable Input/Output Control" gesetzt? Ich vermute, du benutzt Windows XP, oder?

Bei "Select Drive" muss der Laufwerksbuchstabe das des virtuellen Laufwerks sein. Hast du das vielleicht noch nicht geändert?

Der "Mounted Drive Letter" muss auch auf D stehen, weil sich Riva den Installationspfad merkt, von dem es aus installiert wurde.
No-CD-C***s gibts nicht und sind eigentlich auch nicht nötig.

EDIT: In DOSBox brauchst du nichts machen. Alle Einstellungen von DFend werden für die DOSBox übernommen.
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#5
Ich habe "Schatten über Riva" gerade über "DOSBox" von der ISO installiert. Der Installationvorgang verlief völlig problemlos, was noch einmal beweist, dass mit der Einstellung alles stimmt. Nach erfolgreicher Installation des Spiels habe ich den Test zur Musik-Wiedergabe von der CD (bzw. der ISO) durchgeführt. Dabei habe ich folgende Fehlermeldung erhalten:

FEHLER: Es wurde auf eine ungültige Spur zugegriffen.

Ich schließe daraus, dass der Kopierschutz von "Schatten über Riva" Fehler erzeugt, wenn man ein Image des Spiels erstellt. Wohlmöglich brauche ich ein besseres Tool. Womit hast du deine ISO erstellt?
Zitieren
#6
Ich habe dafür Nero genommen, ein NRG-Image erstellt, Nero Imagedrive für ein virtuelles Laufwerk gestartet und läuft fehlerfrei - auch mit Sound.

Aber du hast meine Frage nicht beantwortet. ;)

Du schreibst, dass deine Mountzeile so aussieht: (mount d e:\ -t cdrom)
Daraus schließe ich, dass du die Input/Output Control nicht aktiviert hast.

In meiner Anleitung steht, dass man es für die Platte und das CD-Laufwerk (in deinem Fall das virtuelle) aktivieren muss.

In meiner Mountdatei steht entsprechend noch ein kleiner Zusatz drin: mount d e:\ -t cdrom -ioctl

Wobei das ioctl für besagten Input/Output-Controller steht.

Kopierschutz hat Riva meines Wissens nicht. Es muss gehen. Notfalls hänge ich dir hier meine Conf-Dateien dran, die du in dein DFend-Verzeichnis übernimmst.
Wenn du auch Nero hast, dann kann ich dir auch meine Einstellungen geben, mit denen ich das Image unter Nero erstellt habe. Wichtig ist der RAW-Modus, damit auch die Audiotracks übernommen werden.
Das hast du vermutlich nicht gemacht, weshalb er nun keine Audiospuren vorfindet. :)
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#7
Aoshi schrieb:Ich habe "Schatten über Riva" gerade über "DOSBox" von der ISO installiert. Der Installationvorgang verlief völlig problemlos, was noch einmal beweist, dass mit der Einstellung alles stimmt.
das ist ein bug in der Verwaltung von virtuellen Laufwerken und ISOs in DOSbox, wenn du die ISO brennst würde es mit der gebrannten CD im Laufwerk kein Problemen geben
http://dosbox.sf.net/ schrieb:"ISO 60 %: Support for disk and cdrom images. Seems to work, but didn't get that much testing
benutz lieber ein anderen Laufwerk-Emulator wie der von Nero oder Daemon Tools usw.
Zitieren
#8
Zitat:Wenn du auch Nero hast, dann kann ich dir auch meine Einstellungen geben, mit denen ich das Image unter Nero erstellt habe. Wichtig ist der RAW-Modus, damit auch die Audiotracks übernommen werden.
Das hast du vermutlich nicht gemacht, weshalb er nun keine Audiospuren vorfindet.

Ja daran könnte es liegen. Ich habe das Image nämlich gerade gemountet, und versucht als Audio-CD abzuspielen. Normalerweise müsste der Player die Musik-Tracks 2-13 abspielen - hat er aber nicht. Es scheint tatsächlich so, als würde das Image nur den Daten-Teil der CD enthalten. Ich werde es mal mit diesem RAW-Modus versuchen. Danke für den Tipp.

Zitat:benutz lieber ein anderen Laufwerk-Emulator wie der von Nero oder Daemon Tools usw.

Das tue ich doch. Ich benutze ja schon die ganze Zeit DAEMON Tools.
Zitieren
#9
wenn alles nich hilft, kannst du versuchen die iso auf CD zu brennen oder du brennst dir ne originalversion/ lässt sie dir brennen
Zitieren
#10
Ich habe das Image, so wie du es beschrieben hast, mit Nero erstellt, und jetzt läuft's ohne Probleme. Vielen Dank für die Hilfe!
Zitieren
#11
den 12 götter zum gruße und mögen sie mir endlich beistehen

ich versuche seit stunden eine dsa3-iso-image zu installieren bzw. das spiel zu spielen.
ich benutze dafür daemon-tools, dosbox und teilweise dfend.
ich installiere von der gemounten image(volle install) und starte das spiel per dosbox. das spiel geht an. leider erscheint die ganze zeit die nachricht "schatten über riva-cd einlegen".
ich installierte erneut per dosbox und zum starten benutze ich dfend+anleitung(dfend benötigt zum einstellen ne bereits installierte game.exe). leider brauchte er wieder die cd... . ich stellte bereits -ioctl (-aspi geht nicht), -usecdrom und -label ein, ohne erfolg.
als letztes brannte ich per nero die iso-image auf eine cd und installierte von dieser. leider friert die installation bei readme.txt O_o ein. ich installaierte dann wieder von der cd-image und gab die reale cdrom in dosbox ein. wieder kein erfolg.

muss ich mir ein strick nehmen um mein elend in borons hallen auszurasten? warum bin ich der einzige mit der nervtötenden nachricht...
Zitieren
#12
Hallo Ballian und willkommen im Forum. :wave:

Das virtuelle Laufwerk, dass das ISO geladen hat, muss in der Mountlist als "D:" erscheinen.
Im DFend stellst du das virtuelle Laufwerk als CD-ROM ein und bei "Input-Output Control" das Häkchen setzen (nur wichtig, wenn man Win2000 oder XP hat).

Das ISO erstellst du am besten nochmal und aktivierst den RAW-Modus dabei, damit auch die Audiotracks mitgenommen werden.
Dann probierst du die Installation erneut. :)
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#13
hi crystal, danke für deine schnelle anwort. die riva-iso habe ich mir von Old Games Never DIe heruntergeladen. die image beinhaltete neben der iso-image die 13 bzw. 12 tracks des spiel in mp3 format.
ich habe bei jeder installation zuerst die image bzw. das cd laufwerk in dosbox auf d gemountet und bei dfend immer den input/output häcken gesetzt. ja ich benutzte winxp sp2 :).
Zitieren
#14
Ballian schrieb:die image beinhaltete neben der iso-image die 13 bzw. 12 tracks des spiel in mp3 format.
Install-technisch hast du alles richtig gemacht, aber Riva kann mit MP3 nichts anfangen. Die Audiospuren liegen im Original als WAV-Dateien vor.

Schau doch mal beim bekannten Auktionshaus vorbei. Dort findet sich regelmäßig ein Teil der NLT. ;) Das Original ist halt doch besser und die paar Euro sollten es wert sein. Das Image von der komischen Seite da kannst du jedenfalls löschen.

Oder du konvertierst die MP3-Dateien in WAV...
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#15
darum gehts ja nicht. ich hab das spiel bereits erworben(sonst würd ichs nicht kennen ;)) nur liegts in meiner altem zimmer bei den eltern (verstaubt wohl irgendwo) - deshalb die image.
aber egal. ja ich weiß wie man mp3 dateien in wav umschreibt, aber ich will doch erst nur das spiel endlich zocken. wie komme ich nun über das "schatten über riva-cd einlegen" hinaus?
sag mir bescheid wenn du mal das spiel wieder im kaufhaus siehst... ;)
Zitieren
#16
Poste am besten deine Conf-Datei, dann kann man sehen, was du gemacht hast. :cool:

Ballian schrieb:sag mir bescheid wenn du mal das spiel wieder im kaufhaus siehst... ;)
Nö, bei Ebay gucken musst schon selbst. ;) Woanders gibts das nicht mehr.
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#17
welche conf meinste?
das hier hab ich zuletzt in die autoexec dosbox.conf (ohne defend) reingeschrieben:

mount c e:\
mount d f:\ -t cdrom -ioctl -usecdrom 1 -label DSA3-RIVA (0 und 1 ausprobiert)
C:
cd games
cd riva

ist das gameverzeichnis, dass ich anschließend mit riva gestartet habe.
Zitieren
#18
Ballian schrieb:mount d f:\ -t cdrom -ioctl -usecdrom 1 -label DSA3-RIVA (0 und 1 ausprobiert)

Gib mal in der DosBox-Eingabeaufforderung den Befehl "mount -cd" ein.
Es wird nun die Anzahl verfügbarer CD-Rom-Laufwerke aufgelistet, nummeriert von 0 bis x .
Hier sollte dann auch das virtuelle Laufwerk angezeigt werden, mit der passenden Nummer. Diese musst du dann an der Stelle einsetzten, an der du die 0 und die 1 schon ausprobiert hast, dann müsste es funktionieren.
Sollte das virtuelle Laufwerk aber nicht angezeigt werden, dann wird es von Dosbox nicht akzeptiert. Wahrscheinlich hast du dann etwas mit Deamon-Tools falsch gemacht ...
Ich bin eine Testsignatur
Zitieren
#19
Das -usecdrom und das -label lässt du weg. Das funktioniert auch ohne. Vielleicht in deinem Fall das Problem gewesen. Probiers nochmal aus.
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#20
doch es klappt. es wurden der reale als auch der image-laufwerk angezeigt. hab beide nochmal mit mount und -usecdrom ausprobiert. leider konnte immer noch die fehlermeldung das die cd einzulegen sei.
Zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste