Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um Ihre Login-Informationen zu speichern, wenn Sie registriert sind, und Ihren letzten Besuch, wenn Sie es nicht sind. Cookies sind kleine Textdokumente, die auf Ihrem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies dürfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die Sie gelesen haben und wann Sie zum letzten Mal gelesen haben. Bitte bestätigen Sie, ob Sie diese Cookies akzeptieren oder ablehnen.

Ein Cookie wird in Ihrem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dassIhnen diese Frage erneut gestellt wird. Sie können Ihre Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
DOSBox unter Raspbian-Linux
#1
Ich habe jetzt versucht, DOSBox einmal unter Raspbian-Linux zu installieren, was auch geklappt hat. Aber wenn ich DOSBox im Vollbild-Modus starten lasse, bekomme ich nur ein Bild in der "Standardauflösung" in der Mitte des Bildschirms. (Der Rest des Bildschirms ist schwarz.) Gibt es eine Möglichkeit, das Bild (formatfüllend) zu stretchen, vielleicht mit schmalen Streifen, rechts und links (letzteres, damit das Bild nicht verzerrt wird, auf meinem 16:9-Bildschirm).

Noch läuft DSA nicht, da ich erst noch die Image-Dateien auf die SD-Karte von meinem "Raspberry Pi" kopieren muss. Ich hatte zwar eine externe Festplatte mit einer Image-Dateien gemountet und das Image über die DOSBox-Konfigurationsdatei versucht einbinden zu lassen, doch dies scheitert daran, dass sich die Datei auf einer externen Festplatte befindet, warum auch immer.

Ich würde mich über ein paar Tipps freuen.
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#2
probier mal wegen dem bild
fullresolution=gewünschte Auflösung wxh
output=overlay oder opengl (also nicht surface)
und
aspect=true

das mit der externen festplatte ist komisch müsste eigentlich gehen, in welchem format hast du die formatiert ? (stimmen evtl. nur die rechte nicht? ) bzw. wie mountest du die (kannst du mal fstab oder die mount ausgabe zeigen? )
Zitieren
#3
Nur mal so aus Interesse: Lässt Du DOSBox unter X oder Framebuffer laufen?
Zitieren
#4
Danke für deinen Tipp bzgl. des Bildes, $|#mi. Ich werde es bald ausprobieren.
(26.09.2015, 14:18)Rabenaas schrieb: Nur mal so aus Interesse: Lässt Du DOSBox unter X oder Framebuffer laufen?
Mit "X" meinst du das X-Window-System? Zuletzt lief DOSBox beim mir darunter. Aber nur, weil ich ohne die grafische Benutzeroberfläche von Linux gar kein Bild bekam (schwarzer Bildschirm) und sich DOSBox daraufhin nicht einmal über Strg + F9 beenden ließ. Was ist denn "Framebuffer"?

Das Dateisystem der gemounteten Festplatte ist NTFS. Das benötigte "ntfs-3g" ist installiert. Das Mounten klappt auch, nur die Imagedateien werden anschließend von DOSBox nicht erkannt/gefunden. Mounten tue ich die Festplatte nicht über die fstab, sondern manuell und zwar mit folgendem Befehl:
Code:
sudo mount -t ntfs /dev/sda1 "/media/Externer Datenträger B"
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#5
versuch es mal mit mount -t ntfs -o rw,users,noatime,locale=de_DE.utf8 /dev/sda1 "/media/Externer Datenträger B"
Zitieren
#6
(27.09.2015, 22:46)wiese.hano schrieb: Mit "X" meinst du das X-Window-System?
Genau das.

(27.09.2015, 22:46)wiese.hano schrieb: Was ist denn "Framebuffer"?
Framebuffer ist eine Schnittstelle im Kernel, die Programme direkt auf den Bildschirm zeichnen lässt, ohne den ganzen Client/Server-Kram von X. Das ist natürlich viel Ressourcenschonender, gerade für Pi. Alles was auf SDL basiert, kann automatisch auch auf Framebuffer ausgeben, also z.B. auch vlc.

(27.09.2015, 22:46)wiese.hano schrieb: Zuletzt lief DOSBox beim mir darunter. Aber nur, weil ich ohne die grafische Benutzeroberfläche von Linux gar kein Bild bekam (schwarzer Bildschirm) und sich DOSBox daraufhin nicht einmal über Strg + F9 beenden ließ.
Das kommt daher, dass Strg+F9 eine Tastenkombination von X ist. Es gibt aber ein paar Sachen zu beachten, wenn man DOSBox mit Framebuffer laufen lassen will (siehe hier).
Zitieren
#7
Mit dem Mount-Versuch von $|#mi kann ich nun endlich die Image-Dateien von meiner externen Quelle einbinden. Danke dafür! (Woran genau, liegt es nun? Ich tippe auf "users".)
(28.09.2015, 07:57)Rabenaas schrieb: Das kommt daher, dass Strg+F9 eine Tastenkombination von X ist.
Und gibt es eine Möglichkeit (Tastenkombination) mit der man im FB-Modus aus der DOSBox herauskommt? Mit Alt+F1, wie es in dem verlinkten Beitrag steht?
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#8
ich schätze es liegt an locale=de_DE.utf8 und evtl umlauten oder ähnliches im pfad

(zu beachten: locale=value
This option can be useful when wanting a language specific locale environment. It is however discouraged as it leads to files with untranslatable chars to not be visible.
ich hatte allerdings noch keine problem mit einer platte die auch mit windows[deutsch] verwendet wird)

users bewirkt nur "users:

Allow every user to mount and unmount the filesystem. This option implies the options noexec, nosuid, and nodev"

(von der mount und mount.ntfs manpage)
Zitieren
#9
(29.09.2015, 12:50)wiese.hano schrieb: Und gibt es eine Möglichkeit (Tastenkombination) mit der man im FB-Modus aus der DOSBox herauskommt? Mit Alt+F1, wie es in dem verlinkten Beitrag steht?
Ja, ein Framebuffer gehört zu einer bestimmten Linux-Konsole. Mit Alt+F1 oder F2 usw. wechselst Du im Textmodus die Konsole, und kannst ihn dann per "killall dosbox" abschießen. (Unter X ist das Wechseln standardmäßig auf die Tastenkombination Strg+Alt+F1 gelegt.) Das Wechseln der Konsole funktioniert praktisch immer, solange Du nicht gerade eine Kernel Panic hast, z.B. auch aus SDL im Frambuffer heraus.
Zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste