Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Baldur's Gate mit ToSC (Classic Edition) unter Windows 10
#1
(28.02.2020, 18:45)Zurgrimm schrieb:
(27.02.2020, 22:57)Lippens die Ente schrieb: vielleicht findet Zurgrimm ja mal wieder Zeit seinen schönen Bericht weiterzuschreiben.
Es freut mich zu lesen, dass daran noch Interesse besteht. Vor Anfang Juni (meinem nächsten Urlaub) wird das aber sicherlich nichts.
Eigentlich solle es nun soweit sein und ich wollte BG mal ein Bißchen weiterspielen. Leider vermiest mir Windows 10, auf das ich den Computer Anfang des Jahres updaten musste, derzeit erheblich den Spaß daran.

Zunächst kam, wenn ich das Spiel starten wollte, immer diese Fehlermeldung:
   

Mit dieser Anleitung
https://www.netzwelt.de/anleitung/176179...ielen.html

habe ich dann herausgefunden, dass das wohl ein häufigeres Problem mit älteren spielen ist und DirectPlay wie dort beschrieben aktiviert.

Danach kam dann jedoch diese Fehlermeldung:
   

Hierzu findet man bei einer Google-Suche diverse Meldungen von Spielern, die das gleiche oder ein entsprechendes Problem hatten, aber selten eine Lösung dazu. Der beste Hinweis kam aus dem GOG-Forum:
https://www.gog.com/forum/baldurs_gate_s..._on_launch

Dort liest man, dass es anscheinend ein Problem ist mit der Video-Auflösung, die Win10 nicht mehr unterstützt. Als Lösung wird angeboten:
Zitat:Try starting it in windowed mode. Open baldur.ini and look for the line
Full Screen=1

Change it to
Full Screen=0

If that works, have the window selected and press ALT+ENTER to return to full screen.
Das funktioniert allerdings nur im ersten Teil. D.h. ich kann über die baldur.ini den Vollbildmodus deaktivieren und das Spiel startet dann auch. Sobald ich allerdings in den Vollbildmodus zurückkehren will, kommt wieder dieser Fehler und das Spiel stürzt ab (= wird beendet).

Ob ich es im Fenstermodus wirklich weiter spielen könnte, ist schon zweifelhaft, denn bereits der dortige Fragesteller schreibt einleitend:
Zitat:If I use the .ini file to launch in windowed mode, game works until I get similar "assertion failed" errors and crashes again.
Ungeachtet dessen - was ja auszuprobieren wäre - bedeutet das Spielen von Baldur's Gate im Fenstermodus, in einem sehr kleinen Fenster zu spielen, wo alles winzig ist. Größer ziehen kann man es nicht.

Fällt irgendjemandem noch eine Abhilfe für das Prolem sein? Ich wäre für jede Idee dankbar, da ich nach vier Jahren die Partie ungern unfertig zurücklassen würde. Einen Nicht-Win10-Rechner habe ich aber auch nicht mehr.
"Haut die Säbel auffe Schnäbel."
Zitieren
#2
Ich denke, die praktischste Methode wäre eine virtuelle Maschine, wo man ein echtes Windows XP oder 7 darauf betreibt. Ohne Netzwerkzugang versteht sich, wegen Sicherheit. Nur kurzzeitig, wegen Aktivierung des Windows-Keys.
Enweder über Virtual Box oder das Windows-eigene Hyper-V, das aber leider nur in Windows 10 Professional oder Enterprise vorhanden ist. Mit Windows 10 Home funzt Hyper-V nicht.
Genügend RAM braucht der PC natürlich auch, denn er muss 2 Windows-Systeme gleichzeitig laufen lassen können, ohne dass es ruckelt. Plus das jeweilige Spiel.

Problem wäre dabei gar nicht mal die Beschaffung eines Keys, sondern die Installation der virtuellen Maschine, wenn man mit sowas nicht firm ist. Da könnte man höchstens hergehen, dass sich Zurgrimm mit jemandem abspricht, demjenigen den Key anvertraut, derjenige auf seinem Rechner das System mit dem Key installiert (quasi vorbereitet) und anschließend auf einem privaten Server hochlädt, damit Zurgrimm das System als Image-Datei runterladen und bei sich in der Virtual Box importieren kann.
Keine Ahnung, wie groß Windows XP oder 7 bei der Erstinstallation war, aber Zurgrimm müsste schon damit rechnen, ein paar Gigabyte runterzuladen. Glaube ca. 5 GB waren es Pi mal Daumen, wenn ich nicht irre. Je nachdem, wie stark das Image komprimiert. :think:

Das wäre jetzt mal ein Denkanstoß von meiner Seite, gemacht hab ich selber sowas noch nicht. Wäre aber eine Idee für eigene Projekte...
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#3
Ich hätte einfach mal ausprobiert, ob BG in der DOSBox läuft bzw. sich darüber installieren lässt.
"Alrik war durstig und hat getrunken."
Zitieren
#4
VM dürfte wenig tauglich sein. Ok, das Spiel ist alt, vlt. reicht da die virtuelle Grafikkarte noch, aber bei meinen Versuchen war selbst das Steam-Interface ruckelig, ohne dass da großartig Grafik angezeigt wurde. Wobei ich das Programm eh nicht als sonderlich performant empfinde.

Versuche, meine physisch vorhandene Graka in die VM einzubinden, damit diese die Ressourcen der GPU nutzen kann, haben jedenfalls nicht gefruchtet.
Die der Götter Gunst verloren,
sind verfallen einer Macht -
Die sie führt zu fernen Toren,
und durch sie in ew'ge Nacht.
Zitieren
#5
Zunächst einmal danke für Eure Idee.


(02.06.2020, 14:25)Crystal schrieb: Problem wäre dabei gar nicht mal die Beschaffung eines Keys, sondern die Installation der virtuellen Maschine, wenn man mit sowas nicht firm ist. Da könnte man höchstens hergehen, dass sich Zurgrimm mit jemandem abspricht, demjenigen den Key anvertraut, derjenige auf seinem Rechner das System mit dem Key installiert (quasi vorbereitet) und anschließend auf einem privaten Server hochlädt, damit Zurgrimm das System als Image-Datei runterladen und bei sich in der Virtual Box importieren kann.
Auch wenn das wahrscheinlich eine gute Experten-Lösung wäre, fürchte ich, die VM-Lösung dürfte für mich etwas zu kompliziert sein bzw. dieser Aufwand für den Zweck auch außer Verhältnis stehen.

(02.06.2020, 14:28)Alrik Alrikson schrieb: Ich hätte einfach mal ausprobiert, ob BG in der DOSBox läuft bzw. sich darüber installieren lässt.
Das habe ich gleich ausprobiert. Ja, ich kann in DOSBox/D-Fend Reloaded ein "Windows game profile" erstellen und das Spiel auch über D-Fend starten. Aber wie genau hilft mir das weiter? Wenn ich darin auf Vollbild umschalte, wird das Spiel weiterhin mit der genannten Fehlermeldung beendet. Oder gibt es da innerhalb von DOSBox noch irgendeine Einstellung, die mir helfen könnte?
"Haut die Säbel auffe Schnäbel."
Zitieren
#6
Alternativ könnte man sich auch die Baldurs Gate Enhanced Edition holen, gibt es gerade bei GoG mit Rabatt zu kaufen.
Die laufen dann auch auf neueren Maschienen.

Alternativ gibts auch nen Forum für Baldurs Gate, weiss nicht ob es da noch ne Methode gibt, die hier noch nicht genannt wurde:
https://baldurs-gate.de/index.php

Mehr fällt mir dazu jetzt auch erstmal nicht ein.
Zitieren
#7
(02.06.2020, 20:21)Wintermute101 schrieb: Alternativ könnte man sich auch die Baldurs Gate Enhanced Edition holen, gibt es gerade bei GoG mit Rabatt zu kaufen.
Die laufen dann auch auf neueren Maschienen.
Schon klar, aber das sind ja ganz andere Spiele. Da kann man auch nicht mit einem bestehenden Spielstand weiterspielen.


(02.06.2020, 20:21)Wintermute101 schrieb: Alternativ gibts auch nen Forum für Baldurs  Gate, weiss nicht ob es da noch ne Methode gibt, die hier noch nicht genannt wurde:
https://baldurs-gate.de/index.php
Da habe ich zu dem Thema nichts Weiterführendes gefunden. Es wird vereinzelt auf einen Widescreen-Mod verwiesen, der möglicherweise auch unter Windows 10 Abhilfe schaffen könnte, allerdings leider auch nur begrenzt mit bestehenden Spielständen kompatibel sein soll.
"Haut die Säbel auffe Schnäbel."
Zitieren
#8
(02.06.2020, 19:52)Zurgrimm schrieb: [...]

(02.06.2020, 14:28)Alrik Alrikson schrieb: Ich hätte einfach mal ausprobiert, ob BG in der DOSBox läuft bzw. sich darüber installieren lässt.

Das habe ich gleich ausprobiert. Ja, ich kann in DOSBox/D-Fend Reloaded ein "Windows game profile" erstellen und das Spiel auch über D-Fend starten. Aber wie genau hilft mir das weiter? Wenn ich darin auf Vollbild umschalte, wird das Spiel weiterhin mit der genannten Fehlermeldung beendet. Oder gibt es da innerhalb von DOSBox noch irgendeine Einstellung, die mir helfen könnte?

Unter D-Fend Reloaded kannst Du mit Rechtsklick auf das Spiel-Profil die Einstellungen öffnen und dann unter "Grafikkarte" die Größe des Fensters einstellen, z.B. 1366x768. So hättest Du zumindest das Problem des kleinen Fensters umgangen.

Ansonsten kann man dort auch die emulierte Grafikkarte ändern, eventuell bringt das etwas.
"Alrik war durstig und hat getrunken."
Zitieren
#9
Also keine Ahnung was ich anders gemacht habe, aber bei mir läuft die alte Version ohne Probleme auf Win 10 64bit.
Habe mir gerade die Enhanced-Version von GoG geholt, dann den Key für die Original-Version eingelöst, den man dazu bekommt, das Spiel installiert, beim Starten kommt dann das genannte "DirectPlay"-Fenster, dort habe ich einfach auf "Feature installieren" geklickt.. Danach komme ich ohne Probleme ins Spiel im Vollbildmodus... Vielleicht konfiguriert der GoG-Installer das aber auch anders..
Ich kenne mich im Baldurs-Gate Universum aber nicht so aus, steht aber auf meiner Liste der Spiele die ich mal probieren möchte.
Reden wir denn überhaupt über das selbe Spiel? Scheint ja echt viele Versionen zu geben.. "Tales of the Swoard Coast" - The Original Saga (German)? Bei mir läuft das überhaupt nicht in der DosBox, sondern nativ unter Windows..
Zitieren
#10
(02.06.2020, 22:24)Alrik Alrikson schrieb: Unter D-Fend Reloaded kannst Du mit Rechtsklick auf das Spiel-Profil die Einstellungen öffnen und dann unter "Grafikkarte" die Größe des Fensters einstellen, z.B. 1366x768. So hättest Du zumindest das Problem des kleinen Fensters umgangen.

Ansonsten kann man dort auch die emulierte Grafikkarte ändern, eventuell bringt das etwas.
Für beide Optionen habe ich keine Einstellungsmöglichkeit gefunden. Mit Rechtsklick auf das Spiel-Prifil kann ich "Edit" anwählen. Dann komme ich in dieses Fenster:
   

Tatsächlich gibt es in den DOS-Profilen viel mehr Einstellungsmöglichkeiten. Ein DOS-Profil kann ich für BG I aber nicht anlegen, weil DOSBox/D-Fend erkennt, dass die .exe-Datei kein DOS-, sondern ein Windows-Programm ist.
"Haut die Säbel auffe Schnäbel."
Zitieren
#11
Nach einigem Nachdenken und etwas Suchen im Internet habe ich jetzt vielleicht trotzdem eine Workaround-Lösung gefunden:

Windows 10 bringt ein Tool mit, das sich "Bildschirmlupe" nennt. Die kann man mit "Windowstaste" + "+" aktivieren:
https://support.microsoft.com/de-de/help...ier-to-see

Standardmäßig kann man da allerdings nur in 100%-Schritten vergrößern - was unbehelflich ist, da bei 200 % bereits das BG-Fenster nicht mehr ganz im Bild ist. Es gibt aber eine Einstellungsmöglichkeit für den Zoomfaktor. Wenn ich den auf 25 % stelle und dann nach dem Anstarten von BG I im Fenstermodus dreimal vergräßere (auf 175 %), dann bin ich vom Vollbild nicht mehr weit entfernt und kann im Spiel wieder etwas erkennen.

Es bleibt die Frage, ob das so spielbar ist, denn ...
(02.06.2020, 12:57)Zurgrimm schrieb: Ob ich es im Fenstermodus wirklich weiter spielen könnte, ist schon zweifelhaft, denn bereits der dortige Fragesteller schreibt einleitend:
Zitat:If I use the .ini file to launch in windowed mode, game works until I get similar "assertion failed" errors and crashes again.
Das wird auszuprobieren bleiben.


An dieser Stelle nochmals vielen Dank an alle, die sich wegen meines Problemes Gedanken gemacht haben. :)


EDIT: Ein weiteres erhebliches Komfortproblem dieses Workarounds hat sich schon gezeigt: Im BG-Fenstermodus funktioniert die Scrollfunktion nicht. Normalerweise verschiebt sich der Bildausschnitt wenn man den Mauszeiger an den Rand des sichtbaren Ausschnitts bewegt. Nicht aber so im Fenstermodus. Hier wird nur dann gescollt, wenn der Mauszeiger außerhalb des Fenster am Seitenrand des Monitors ist. Wenn man mit der Bildschirmlupe arbeitet bedeutet das aber, dass der Mauszeiger zum jeweiligen Rand des vergößerten Bildschirms geführt werden muss, wodurch das vergößerte Spielfenster aus dem sichtbaren Bereich des Monitors heraus verschiebt. Einzige Abhilfe: Scrollen über die Pfeiltasten des Tastenblocks. Das ist zum einen eine erhebliche Ungewöhnung und geht zum anderen nicht flüssig, sondern erheblich ruckelig. :rolleyes:
"Haut die Säbel auffe Schnäbel."
Zitieren
#12
Wenn Windows weiter rumzickt, dann geht immer noch https://gemrb.github.io/
Walisischer Käsetoast [Bild: kaesetoast.png]
Zitieren
#13
(03.06.2020, 09:03)Zurgrimm schrieb:
(02.06.2020, 22:24)Alrik Alrikson schrieb: Unter D-Fend Reloaded kannst Du mit Rechtsklick auf das Spiel-Profil die Einstellungen öffnen und dann unter "Grafikkarte" die Größe des Fensters einstellen, z.B. 1366x768. So hättest Du zumindest das Problem des kleinen Fensters umgangen.

Ansonsten kann man dort auch die emulierte Grafikkarte ändern, eventuell bringt das etwas.
Für beide Optionen habe ich keine Einstellungsmöglichkeit gefunden. Mit Rechtsklick auf das Spiel-Prifil kann ich "Edit" anwählen. Dann komme ich in dieses Fenster:


Tatsächlich gibt es in den DOS-Profilen viel mehr Einstellungsmöglichkeiten. Ein DOS-Profil kann ich für BG I aber nicht anlegen, weil DOSBox/D-Fend erkennt, dass die .exe-Datei kein DOS-, sondern ein Windows-Programm ist.

Hmm, okay, das ist blöd. Ich hatte darauf spekuliert, dass es diese Einstellungsmöglichkeiten weiterhin gibt.
"Alrik war durstig und hat getrunken."
Zitieren
#14
(03.06.2020, 10:33)Rabenaas schrieb: Wenn Windows weiter rumzickt, dann geht immer noch https://gemrb.github.io/
Das klingt auf den ersten Blick interessant. Hast du das schon ausprobiert? Wie funktioniert es?
"Haut die Säbel auffe Schnäbel."
Zitieren
#15
So, ich habe es jetzt versucht, aber ich bekomme GemRB nicht zum laufen.

Auf der von Dir verlinkten Seite heißt es unter "Download and run", Abschnitt "Install":
Zitat:The downloads do not come with installers, so just unpack them and run GemRB. MacOS is the only exception with its bundle. On Windows make sure you have the Visual Studio 2013 Redistributable (2017 for development builds), as GemRB will fail to start without two of its DLLs.
Ich habe also GemRB heruntergeladen und entpackt. In dem Ornder befindet sich nur eine ausführbare Datei, die gemrb.exe. Wenn ich diese anstarte, blitzt nur kurz ein Fenster auf, das sofort wieder geschlossen wird.

Also bin ich dem Link zu dem Visual Studio 2013 Redistributable (2017 for development builds) gefolgt. Dort hat zunächst kein Download gestartet. auswählen kann man bei manuellem Anstarten zwischen vcredist_arm.exe, vcredist_x64.exe und vcredist_x86.exe.

Ich habe vorsorglich alle drei heruntergeladen. Die vcredist_arm.exe lässt sich nicht anstarten, da gibt es eine Fehlermeldung. Die beiden anderen haben ein Setup erfolgreich durchgeführt, laut Meldung. Ich vermute also, nun Visual Studio 2013 erfolgreich installiert zu haben.

Gleichwohl lässt sich remrb.exe nicht starten.

Um überhaupt eine Fehlermeldung angezeigt zu bekommen, habe ich es über die Kommandozeile ("cmd") angestartet. Dort hieß es dann:
Zitat:[Core]: GemRB Core Version vtags/v0.8.6, ,  Loading...
[Core]: Initializing the Event Manager...
[Core]: Starting Plugin Manager...
[PluginMgr]: Loading Plugins from C:/gemrb-win32-196c54e/plugins
[PluginLoader/ERROR]: Error looking up dlls.
[PluginLoader/ERROR]: Cannot find any plugins!
[Core/FATAL]: Plugin Loading Failed, check path...
[Main]: Aborting due to fatal error...
Dem habe ich entnommen, dass das Progamm davon ausgeht, dass der Entpack-Ordner "gemrb-win32-196c54e" direkt unter "C:" liegt. Folglich habe ich den Ordner dorthin kopiert und die gemrb.exe erneut angestartet. Es folgt aber das gleiche Ergebnis mit der gleihen Fehlermeldung.

Hat jemand eine Idee?
"Haut die Säbel auffe Schnäbel."
Zitieren
#16
Das die ARM-Version von der Vcredist nicht installierbar war, liegt daran dass das nur für ARM Prozessoren ist, die man meistens in Handys oder Tablets findet. Auf dem PC ist es eigentlich immer x86.
Zu  GemRB: Man muss die GemRB.cfg.sample umbenennen in GemRB.cfg und dann bearbeiten:
- An die Stelle GamePath muss der Pfad zum Spiel, bei mir ist das z.B. das hier:
  Wichtig sind die \\
GamePath=C:\\GOG Games\\Baldur's Gate (German)\\
- An die Stelle PluginsPath muss der Pfad zu den Plugins, hier das # zu Beginn entfernen und die / mit \\ ersetzen:
PluginsPath=C:\\gemrb-win32-196c54e\\plugins

Hast du Python 2.7 schon installiert? Wenn nicht gibt es das hier: https://www.python.org/downloads/release/python-2718/
Nicht versuchen, Python 3 zu installieren, die Verson ist nämlich nicht abwärtskompatibel.

Unbedingt die Windows x86 MSI Installer Version installieren, nicht den Windows x86-64 MSI Installer.
Im Installationsmenü ist es dann noch notwendig Python zu PATH hinzufügen, dafür muss man eine Checkbox setzen (Ich glaube dann sind alle gesetzt, aber wie gesagt, den Haken muss man noch selber setzen). Danach startet bei mir mit Klick auf GemRB das Spiel.
Falls jetzt etwas schiefgelaufen ist, und es wieder eine Fehlermeldung schmeißt (über die Konsole testen), kann man hier die häufigsten Ursachen unter 4. nachlesen: http://www.gemrb.org/wiki/doku.php?id=install:windows

SO sollete es eigentlich gehen, das Spiel startet bei mir dann noch im Fenstermodus,
um den Vollbildmodus zu aktivieren muss man schlussendlich nochmal in die GemRB.cfg und die Zeile Fullscreen=0 in Fullscreen=1 abändern.
Viel Spaß!
Falls das aber auch nicht geht würde dir ansonsten empfehlen mal die GoG Non-Enhanced Version des Spiels zu probieren, die scheint so konfiguriert, dass sie auf Windows 10 ohne Probleme läuft.. Bei mir läuft die außerdem auch etwas runder wie mit der GemRB Engine..

Edit: Weitere Idee: Beim Stöbern in der GemRB.cfg ist mir aufgefallen, das von BG1 wohl scheinbar keine HD-Auflösungen unterstützt werden. Schonmal versucht die Auflösung zum Spielen auf 1280x1024 oder so herunterzusetzen? (Dann sollte es bei einem Breitbildmonitor links und rechts schwarze Balken geben)
Zitieren
#17
Oha, das ist ja doch komplizierter, als ich dachte. Aber schonmal danke für die Anleitung, cmfrydos.


(03.06.2020, 20:35)cmfrydos schrieb: Im Installationsmenü ist es dann noch notwendig Python zu PATH hinzufügen, dafür muss man eine Checkbox setzen (Ich glaube dann sind alle gesetzt, aber wie gesagt, den Haken muss man noch selber setzen).
Da gibt es zwei Optionen zu wählen:
- "Will be installed on local hard drive" und
- "Entire feature will be installed on local hard drive".

Welches ist die richtige Option für PATH?

(03.06.2020, 20:35)cmfrydos schrieb: Falls das aber auch nicht geht würde dir ansonsten empfehlen mal die GoG Non-Enhanced Version des Spiels zu probieren,
Als ich geschaut habe, gab es bei GOG nur noch die Enhanced Edition zu kaufen; jedenfalls auf deutsch.


(03.06.2020, 20:35)cmfrydos schrieb: Schonmal versucht die Auflösung zum Spielen auf 1280x1024 oder so herunterzusetzen?
Es gibt in BG1 leider keine Option, die Auflösung einzustellen.
"Haut die Säbel auffe Schnäbel."
Zitieren
#18
Mein letzter Durchgang ist lange her. Die Installation war hakelig, aber ich musste gemrb vorner noch kompilieren. Als es lief, lief es stabil mit vielen praktischen Mods, u.a. verbesserter Auflösung.

cmfrydos kann Dir im Moment wesentlich besser weiterhelfen, also drücke ich die Daumen....
Walisischer Käsetoast [Bild: kaesetoast.png]
Zitieren
#19
Wäre es evtl sinnvoll, das Thema BG1 unter Windows 10 abzuteilen? Das scheint doch durchaus zukünftig auch noch interessant zu sein und man könnte es dann leichter finden.
Zitieren
#20
Ja, denke das würde passen @aeyol
Zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste