Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Das schwarze Auge und Linux
#41
(17.04.2019, 16:42)Alrik Normalpaktierer schrieb: Was mache ich falsch? Würde cue/bin statt iso funktionieren?
Ja, Teil des Kopierschutzes ist das die CD-ROM im Laufwerk sein musste, um das zu überprüfen schaut RIVA.EXE unter anderem ob die richtige Anzahl CD-Tracks vorhanden sind. Wenn nur die Dateien des Daten-Tracks in ein Verzeichnis kopiert oder ein ISO-Image (ein Abbild des Daten-Tracks) verwendet schlägt diese Überprüfung fehl da die Audio-Tracks nicht gefunden werden. BIN/CUE Images können alle Daten- und Audiotracks abbilden, und somit benutzt werden um dieser Überprüfung standzuhalten.
Zitieren
#42
Das ist kein Linux-Problem.

Guck mal hier: Image-Dateien von CDs
Zitieren
#43
Uuuund - es funktioniert! Vielen lieben Dank!

Zunächst gab es noch Probleme mit dem .cue. Aber als ich statt der selbst erzeugten Datei einfach eine benutzt habe, die hier im Forum zur Verfügung gestellt wurde, klappte es sofort. Und sogar mit der richtigen Musik, also besser als bei dem Versuch mit eingelegter CD.
Super!
Zitieren
#44
Ich habe die DOSBox nun unter Raspbian Buster auf meinem Raspberry Pi installiert. Nun habe ich folgendes Problem: Wenn ich die DOSBox starte und versuche, die Tastatur zu benutzen, erscheint bei jedem Tastendruck - egal, ob es sich um Buchstaben, Ziffern, Symbole oder Funktionstasten handelt - ein anderes Zeichen, also nie das Zeichen, welches ich gedrückt habe. Es scheint, als sei die Keymap komplett durcheinander gekommen. Kann sich das einer erklären und/oder hat vielleicht eine Idee, was ich dagegen tun kann?
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#45
Vermutlich handelt es sich dabei um die EN-US-Keymap. ('y' für 'z' und umgekehrt z.B.)
BOSBox verwaltet seine eigene Keymap. Wenn deu Standard-DE-Layout wünschst, kannst Du z.B.
Code:
keyb gr
in die autoexe.bat schreben. Das hat nicht speziell mit dem RasPi zu tun.
Zitieren
#46
(06.09.2019, 20:32)Rabenaas schrieb: Vermutlich handelt es sich dabei um die EN-US-Keymap. ('y' für 'z' und umgekehrt z.B.)
Eben nicht. Kein einziger Buchstabe auf der Tastatur stimmt! U ist z.B. Backspace. J ist die Eingabetaste.
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#47
Interessant. Bei Stretch funktioniert das hier ganz normal. Hast Du "keyb gr" in die dosbox.conf geschrieben?
Benutzt Du ein ganz normales USB-Keyboard?
Zitieren
#48
Hast du schon versucht, eine andere Tastatur anzuschließen? Tritt der Fehler dort auch auf?
--------
Warnung! Geschichte kann zu Einsichten führen und verursacht Bewusstsein!
Avatar by: Keven Law (CC BY-SA 2.0)
Zitieren
#49
Ich habe

Code:
keyboardlayout=auto
ersetzt mit

Code:
keyboardlayout=gr


Damit erreiche ich nichts. Die Tastatur ist eine normale USB-Tastatur mit integriertem USB-Hub. Ich habe sonst unter Linux keinerlei Probleme mit der Tastatur. Ein andere Tastatur zum Testen habe ich nicht.

Einmal gestartet, komme ich dann auch nicht mehr aus der DOSBox heraus, weil ich "exit" nicht tippen kann und bei manchen Tasten (z.B. ESC) hängt sich die DOSBox auf, sodass ich den Raspberry Pi nur noch hart ausschalten kann.

Was passiert eigentlich, wenn ich folgendes eintrage:
Code:
keyboardlayout=none
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#50
(07.09.2019, 10:10)wiese.hano schrieb: Was passiert eigentlich, wenn ich folgendes eintrage:
Code:
keyboardlayout=none

Dann kannst du vermutlich deine Tastatur nicht mehr benutzen. DOSBox denkt, sie wäre nicht angeschlossen. "None" heißt schlicht "Keine".
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#51
Wenn bei J ein "Enter" interpretiert wird, heißt das, dass deine Strg-Taste als ständig gedrück erkannt wird. Ctrl+J ist eine alternative Eingabe für Ascii-Code 10 (Linefeed). Das Verhalten bei U passt da auch rein.
Zitieren
#52
Das mit der permanent gedrückten STRG-Taste könnte sein. Da ich diese Taste aber de facto nicht drücke und diese auch kein Funktion in der Art eines CAPS-Lock hat und in Anbetracht der Tatsache, dass dieses Problem nur in der DOSBox unter Linux, nicht aber unter Linux selbst auftritt, weiß ich mir keinen Rat, das Problem zu beheben. Scheint so, als müsste eine neue/andere Tastatur her.

Ich habe noch einen anderen kuriosen Effekt. Vielleicht hängt ja beides zusammen, obwohl eher unwahrscheinlich.

Bei den PIs macht man das ja in der Regel so, dass man sich das Raspbian-Image herunterlädt, auf die SD-Karte schreibt, die SD-Karte in den Pi steckt und dann den Pi hochfährt.

Als ich das mit dem derzeit genutzten System ("Buster" heißt die aktuelle Raspbian-Version), wunderte ich mich, dass ich mich nach dem Hochfahren nicht mit dem Standardpasswort ("raspberry") anmelden konnte. Auch "raspberrz" ging nicht.

Schließlich fand ich heraus, dass ich mich mit einem anderen Passwort anmelden muss, nämlich mit einem, dass ich früher mal für eine ganz andere Raspbian-Version benutzt habe.

Das seltsame ist: Das ist eigentlich gar nicht möglich, da ich die Image-Datei, die ich auf die SD-Karte kopiert habe, in keiner Weise manipultiert habe und diese frisch aus dem Internt kam.

Gerne eure (wilden) Spekulationen dazu. *g*
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#53
Nein, du brauchst keine neue Tastatur. Ich meinte das, dass die Dosbox die Strg-Taste als gedrück erkennt (warum auch immer), also ein Software-Problem. Solche Probleme kenne ich eigentlich nur von Remote-Desktop-Software wenn z.B. bei gedrückter Alt-Taste das Fenster den Fokus verliert usw. Bei der Dosbox hatte ich es persönlich noch nicht und es war nur als Hilfe zum Google füttern gedacht.

Zu deinem PI-Image-Problem: Vielleicht aus Versehen ein altes Backup-Image wieder aufgespielt? ;)
Zitieren
#54
(06.09.2019, 22:13)Rabenaas schrieb: Interessant. Bei Stretch funktioniert das hier ganz normal.
Also, habe es jetzt noch mit Stretch probiert. Selbes Problem. Keine Taste hat mehr ihre ursprüngliche Funktion.
"Save early and save often!" - Speichere oft und speichere früh! - Ist eine alte Zockerweisheit.
Zitieren
#55
Hat Du Dir die Keycodes mal mit xev angesehen?
Zitieren




Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste