Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um Ihre Login-Informationen zu speichern, wenn Sie registriert sind, und Ihren letzten Besuch, wenn Sie es nicht sind. Cookies sind kleine Textdokumente, die auf Ihrem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies dürfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die Sie gelesen haben und wann Sie zum letzten Mal gelesen haben. Bitte bestätigen Sie, ob Sie diese Cookies akzeptieren oder ablehnen.

Ein Cookie wird in Ihrem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dassIhnen diese Frage erneut gestellt wird. Sie können Ihre Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Bitte 'Schatten über Riva'-CD einlegen
#41
@Piro:

Wenn Dein Bruder keine CD mehr hat, ich habe hier noch eine rumliegen. Die kannst Du gerne gegen Erstattung der Versandkosten geschenkt haben...

Markus
Zitieren
#42
Hey, Leute!

Erstmal vielen Dank für die Antworten!
Ich hatte schon vefürchtet, dass es an den Autio-Tracks liegen könnte, wußte mir aber keinen Rat mehr.

@marric1976: Danke für das Angebot. Hab meinen Bruder auch schon drauf angesetzt und warte auf seine Antwort. Wenn er sie nicht findet, komm ich gern auf dich zurück!
Zitieren
#43
Den Zwölfen zum Gruße!

(10.10.2009, 14:25)Bootsmann schrieb: Ich habe mir daraufhin einen alten Spielstand genommen, ihn in den ../RIVA/GAMES - Ordner kopiert und in LASTGAME (Ohne Dateiendung!) umbenannt. Die alte LASTGAME-Datei musste natürlich vorher beseitigt werden. Ausserdem habe ich den alten Spielstand selbst noch im ../RIVA/GAMES - Order mit der Endung .gam abgespeichert.

Seitdem startet das Spiel und überspringt das Intro :)

Ich fasse nochmal kurz zusammen:

Das Intro in Riva kann übersprungen werden, wenn die Datei LASTGAME im ../RIVA/GAMES - Ordner durch einen anderen, in LASTGAME umbenannten, Spielstand ersetzt wird. (EDIT: Der dafür verwendete Spielstand darf nicht START.GAM sein)

Kleine Ergänzung von mir: Ich hatte das kuriose Problem, dass bei mir immer das Intro abgespielt wurde. Ich hatte "Schatten über Riva" zweimal installiert, mit der ersten Installation zu spielen angefangen und wollte dann mit der zweiten weiterspielen. (Ich wollte den Unterschied zwischen Riva plus Patch einerseits und Riva plus Lösungshilfe plus Patch andererseits vergleichen. Nach dem Vergleich war die erste Version überflüssig.) Bei der Gelegenheit habe ich die meisten Spielstände in ein Unterverzeichnis verschoben, um im Spiel nicht immer eine Riesenliste zu sehen.

Seltsamerweise wird das Intro bei jedem Start geladen, auch wenn LASTGAME einen Spielstand aus dem Spiel darstellt. Abstellen ließ sich das, indem ich den Spielstand START.GAM wieder in das GAMES-Verzeichnis kopiert habe. Unlogisch, aber wahr!
Ärger im Svellttal? Auf der Suche nach dem Salamanderstein? Dann hilft der Sternenschweif-Reiseführer von Kunar!
Zitieren
#44
ok will gleich ma nen danke hier anbringen durch die ganzen links zu anderen forenbeiträgen

Ich hatte das problem mit der cd auch und nach runterstellen der Dosbox geschwindigkeit lief es dann wunderbar mit sound und keine probs eig :)
Zitieren
#45
Gude,

(24.05.2010, 22:35)Kunar schrieb: Abstellen ließ sich das, indem ich den Spielstand START.GAM wieder in das GAMES-Verzeichnis kopiert habe. Unlogisch, aber wahr!

Was ich jetzt nicht ganz nachvollziehen kann ist, dass du START.GAM aus dem GAMES-Verzeichnis entfernt hast.
Habe gerade kein DSA installiert und kanns nicht testen, aber ich gehe davon aus, dass wenn man die Datei START.GAM aus dem GAMES-Verzeichnis entfernt jedes mal das Intro abgespielt wird.

Meine Theorie dazu:
Vermutlich eine Abfrage wie z.B.
Wenn START.GAM vorhanden und START.GAM ungleich LASTGAME
lade LASTGAME ohne Intro
andernfalls
lade LASTGAME mit Intro

Eine solche Abfrage "START.GAM vorhanden ?" wäre unnötig und ein Fehler bzw. unnützer Codeteil der auch mir beim proggen schnell ma passiert, weil man da einfach ein bisschen "abgehobener" denkt. Beim Betatesten und der Fehlersuche fällt sowas nicht auf, erst wenn man ein Handbuch zum Quelltext schreibt und noch einmal seinen eigenen Code hinterfragen muss. Macht aber kaum jemand.

Wie gesagt nur ne Theorie.
Zitieren
#46
Da ich auf einem Netbook spiele und nur ein IMG meiner CD hatte, hatte ich lange ähnliche Probleme. Mitlerweile habe ich aber eine gute funktionierende Lösung gefunden:

1. Man muss ein Mixed Mode Image erstellen. Diese sollte das Dateiformat bin/cue haben. Zur Not kann man natürlich auch ein anderes image erstellen (bspw. mdf/mds) und dieses dann konvertieren (z.B. UltraIso - läuft auch unter WINE).
2. in Dosbox braucht man dann den Befehl imgmount, siehe auch hier: http://www.dosbox.com/wiki/IMGMOUNT
z.B. imgmount D C:\image\pfad\image.cue -t iso -fs iso
(nicht die bin mounten, die cue mounten)
3. Nachdem das image auf D gemountet wurde, nur noch installieren, danach läuft alles super.
Zitieren
#47
Hallo zusammen,

ich nutze D-Fend Reloaded und habe versucht Schatten über Riva darauf zu installieren. Von Meiner Original-CD (Gold Games 2-Sammlung) habe ich eine ISO-Datei erstellt. Aus dieser ISO habe ich mit dem Programm PowerISO die BIN/CUE-Dateien erstellt. Heißt also das ich folgende drei Dateien habe:

riva.bin 619.991 KB
riva.cue 1 KB
riva.iso 539.856 KB

In D-Fend Reloaded habe ich über Hinzufügen -> von Quellmedium installieren -> von CD-Image installieren -> riva.cue gewählt. In der DOSBoxoberfläche dann D:\>install, anschließend startet der Installationsbildschirm. Bei der Testwiedergabe für die Musik steht bei mir folgende Meldung "FEHLER: Es wurde auf eine ungültige Spur zugegriffen". Den Rest der Installation konnte ich komplett abschließen. Am Ende heißt es aber dann "Bitte 'Schatten über Riva'-CD" einlegen. Habe ich bei meiner Installation etwas falsch gemacht oder liegt es eventuell an meinem Betriebssystem (Windows 10, 64bit)?
Zitieren
#48
Hallo Turaltay, öffne die Datei riva.cue mit einem Texteditor und prüf nach, ob Audiotracks eingetragen sind. DOSBox ist vollkommen unabhängig vom gefahrenen Betriebssystem, von daher tippe ich auf ein fehlerhaft erstelltes BIN/CUE-Image.
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#49
(08.05.2019, 21:29)Crystal schrieb: Hallo Turaltay, öffne die Datei riva.cue mit einem Texteditor und prüf nach, ob Audiotracks eingetragen sind. DOSBox ist vollkommen unabhängig vom gefahrenen Betriebssystem, von daher tippe ich auf ein fehlerhaft erstelltes BIN/CUE-Image.

Danke für die schnelle Antwort. Folgender Inhalt befindet sich in riva.cue:

FILE "riva.bin" BINARY
  TRACK 01 MODE1/2352
    INDEX 01 00:00:00

Welches Programm wäre dann zur Erstellung des BIN/CUE-Image empfehlenswert, wenn die Datei fehlerhaft ist?
Zitieren
#50
Probiere imgburn aus und halte dich an die Anleitung auf https://www.disc-media.de/wissen-wie-man...-erstellt/
wo du auch auf imgburn hingewiesen wirst. Das sollte gehen, denn in deiner riva.cue steht nur Track 01 drin und dort liegt das Spiel selbst. Die Audiotracks liegen in Track 02, 03, 04, etc. und müssen ebenfalls in der cue drinstehen, was sie aber nicht tun, deshalb fordert er dich zum CD-Wechsel auf.
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#51
(08.05.2019, 21:16)Turaltay schrieb: Aus dieser ISO habe ich mit dem Programm PowerISO die BIN/CUE-Dateien erstellt.
Beim Umwandeln einer MixedMode CD in ein ISO gehen die Musiktracks verloren. Das ISO enthält nur den Datentrack. Wenn Du anschließend ein CUE/BIN daraus machst, bringt das die Musik auch nicht wieder zurück. Nur als Erklärung, was schief gelaufen ist.
Zitieren
#52
(08.05.2019, 22:32)Rabenaas schrieb:
(08.05.2019, 21:16)Turaltay schrieb: Aus dieser ISO habe ich mit dem Programm PowerISO die BIN/CUE-Dateien erstellt.
Beim Umwandeln einer MixedMode CD in ein ISO gehen die Musiktracks verloren. Das ISO enthält nur den Datentrack. Wenn Du anschließend ein CUE/BIN daraus machst, bringt das die Musik auch nicht wieder zurück. Nur als Erklärung, was schief gelaufen ist.

Heißt also ich muss meinen Original-Datenträger zur Erstellung der CUE/BIN verwenden? Dann muss ich morgen mal meine CD-Sammlung durchforsten. Danke für den Hinweis!
Zitieren
#53
Korrekt, Images immer von physischen Datenträgern ziehen.
Zum NLT-Wiki: http://nlt-wiki.crystals-dsa-foren.de/doku.php , Zum Drakensang-Wiki: http://drakensang-wiki.crystals-dsa-foren.de/doku.php
KEIN SUPPORT per E-Mail, PN, IRC, ICQ! Lest die Regeln und benutzt das Forum für sämtliche Anfragen! KEINE persönliche Betreuung!
Zitieren
#54
Habe jetzt mit ImgBurn und der Original-CD erneut die CUE/BIN erstellt. Spiel lässt sich vollständig installieren und funktioniert jetzt. Vielen Dank für die Tipps!
Zitieren




Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste